Owners of Pre-2012 Kindles Need to Update

Pre-2012 Kindles need to be updated by the end of today.

If you have a Kindle that was purchased in 2012 or earlier and you want to keep using it to access new books, you need to install a critical update no later than TODAY.  (Otherwise it will be more difficult to update in future.)

Details on installing the update can be found here.

Would it be snarky to mention that paper books don’t need to be upgraded?  Probably.

Related articles

Epic Fantasy Analysis March 14, 2013

This is the fifth in the series and is from data as of 3/14/2013. Links to review previous data: 01/03/2013 01/24/2013 02/17/2013 03/03/2013   As always this data comes from the   Amazon Kindle Epic Fantasy Bestseller List. For readers, you’ll be able to see what authors are selling well and find some titles that are worth […]

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.